Porsche 718 Forum banner
221 - 240 of 261 Posts

·
Registered
Joined
·
10 Posts
@Shodanbo

so far I thought you have to press one button 1st and the other one a very short moment later to make it work.
Just tested. AFAIK you have to hit the buttons at the same time. After ~5 seconds the hit combo will take effect.

First I tried hitting TUNER and then MEDIA quickly and the result was that the PCM tuner UI is displayed.

Next I tried hitting both at the same time. After ~5 seconds GEM comes up. This is after the MIB install and firmware patch process.

Originally I brought up the developer menu (CAR + MEDIA) to perform the update needed to start the process of installing the patch (MHI2_US_POG11_P5103_MU1349_PATCH for my head unit)

Here is a link showing an mp4 video of the process. First I try TUNER then MEDIA. Then I try both at the same time.

In the video you can hear a single "click" the second time.

Given that I am a human and not a computer I doubt that the 2 buttons are actuated at precisely the same time. But the only way I can get this to work on my head unit is to try and hit them at the same time :cool:

https://cchristine.com/videos/projects/boxtergts2019/gem.mp4

This is a 2019 Boxter GTS (North America, United States). Head unit firmware as shown below.

Gadget Font Audio equipment Communication Device Display device
 

·
Registered
Joined
·
10 Posts
Thanks for the test!

Could it be, that you tried 1. Tuner + 2. CAR?
At least that is what I can see on the video.

1. CAR + 2. TUNER would be "right" :)
I tried several orders when creating the video. Unfortunately the first video I got that did not involve me screwing up and forgetting to go back to the HOME screen had me hitting TUNER first 😖

And I was using one hand when taking the video 🤔

So I just tested with 2 hands.

You are correct. If you hit CAR first and then TUNER before the car screen is displayed this works. I could not do this by hitting TUNER first.

And so the 1/2 punch technique works and the order is important 🎉

I would say anecdotally that the timing window involved is somewhere between 50 - 200 ms.

I would also say that hitting the buttons at the same time also works. For me this was easier to pull off without practice and so this is what I ended up doing :)
 

·
Registered
Joined
·
1 Posts
I would say, we have a win win situation here!

Old method confirmed and new found!

will add yours to the wiki.
Hello MIB-Wiki, I want to thank you for contributing to the community. I was able to utilize your MIB and gem software and did the AIO and successfully activated android auto on my PCM (pog11).

i'm now trying to update the NAV maps.

My car had NAV already activated from the factory.


current version

SOFTWARE:MHI2_US_POG11_P4151 1097
HARDWARE:054
NAVIGATION DATABASE:V03959802GS 0060 NAR 2017/2018

I went into the MIB Solution to find the map updates, is the one circled below the correct one for my US porsche 718 POG11? (P85_N60S5MIBH3_NAR_NT_Q1.21.7z )
View attachment 43553

Additionally, do I just put it on the SD card (root of SD card?) and just update the NAV database via NAV -options?

THANKS in advance :)
 

·
Registered
Joined
·
10 Posts
Anyone here who wants to test? View attachment 42107
Giving it a shot now. I had originally updated the PCM with an older build and it had the weird Android Auto icon.

This is using the following from MIB Solution :: Login

M.I.B_3.3.1_20220616.zip
M.I.B_Patches_20220611.7z

The relevant patch for my head unit is
MHI2_US_POG11_P5103_MU1349_PATCH

Following instructions from

From what I can tell the first software updated reverted my head unit back to stock. A second update then re-installed using the latest stuff. You can see me attempting to bring up GEM after the first install and I cannot do it. A second install gets GEM back.

Here is a video of the process. Video starts right after entering engineering menu, starting the update and waiting for the head unit to reboot.


After the second update I have the new AA logo

Gadget Communication Device Personal luxury car Technology Electronic device


And I can bring it up as shown below.

Plant White Black Motor vehicle Mode of transport


At the end of the video you can see me go to the "Enable AA button" screen. It looks like this was unnecessary.
 

·
Registered
Joined
·
60 Posts
Yes, AA button fix is already installed as part of the AIO patching (if a fitting FW is detected).

In your video the patch file on SD was not found.
Did you patch before, as AA seems to be working now?

GEM activation as part of the M.I.B installation normally works. It could be, that GEM was not yet ready after reboot.
It sometimes needs a bit.
 

·
Registered
Joined
·
1 Posts
Thanks MIB, here is my first track test of the Track Precision App. There is also Android Auto screen mirroring video in my YouTube channel, so RaceChrono is an option.

At first, I tried external GPS receivers, both Dual XGPS 160 and VBOX Sport. XGPS failed and VBOX didn't work well either. At last, to my big surprise, when I turned off bluetooth, the recording became perfect. It proved the GPS antenna was already installed in my car with no Navi option. And the car is indeed optimized for the app, just as the app introduction says.

I also figured out how to show Delta T in the app, and some other interesting findings, which can be found in my video description.
 

·
Registered
Joined
·
7 Posts
Just guessing, but perhaps the update makes the PCM appear different or has reset the activation or changed the online code that is now needed associated with your car.

I thought that it was strange the process required a trip to the service department to enable it, maybe they need to use the PIWIS to talk to the PCM again for them to generate a new code?
That was my thought as well... But I solved it yesterday. It was SO SILLY :p I noticed that the time was incorrect (not adjusted for summer time...)...and I know that for HTTPS (for the online connection) to work the time needs to be correct. I set the correct time, rebooted the unit and it worked :D
 

·
Registered
Joined
·
185 Posts
Thanks MIB, here is my first track test of the Track Precision App. There is also Android Auto screen mirroring video in my YouTube channel, so RaceChrono is an option.

At first, I tried external GPS receivers, both Dual XGPS 160 and VBOX Sport. XGPS failed and VBOX didn't work well either. At last, to my big surprise, when I turned off bluetooth, the recording became perfect. It proved the GPS antenna was already installed in my car with no Navi option. And the car is indeed optimized for the app, just as the app introduction says.
This is what I'm looking to do! I have a base 2.0T, Sports Chrono, no nav, no wifi (but AA enabled thru a vendor), base stereo. Would this work for me??
 

·
Registered
Joined
·
5 Posts
Hi Everyone,

First I wanted to thank all the community for the amazing job done in the forum, this is great to see so many active and passionate people.

On my side, I plan to buy my future 718 (type 982) in the next 2-3 months and I am currently looking for the right model.

Because Apple Carplay seems not to be a popular option on the used market, I am really interesting for installing it after.

Reading all this DIY and it seems the method is now pretty simple since we can do everything with a SD.
I have not found the answer to my remaining questions so excuse me if this was in this thread or another place but could not find them.

Is anyone can tell me the benefit to use an external module like the one here: Added smart module to get Apple CarPlay access | Porsche 718 Forum versus installing the software directly.

Is this method (software) compatible with all 718/982 or only if some previous options are mandatory first before installing the MIB and use the GEM?

Because if I understood correctly, if we have a PCM (any version) installed we can:
1-install MIB
2-access GEM
3-activate Apple Car play (without any license key?)

Am I right?

thank you so much for clarification
 

·
Registered
Joined
·
60 Posts
Which MJ are you looking at?

If the car is equipped with a MIB2 unit, there is no good reason to go with an external module.
Better use the factory made solution.

In some rare cases I have seen that GPS antenna was not connected to car. But this can easily fixed for 10-20 bugs.

Check GitHub on how to see train version and make sure you buy a car with MHI2 based navigation system.
In that case CP/AA, navigation and more can be added by M.I.B.

Wireless CP can be added with a 50 bugs module from Ali.
And yes, @starweb9 could have done it without the external module.
 

·
Registered
Joined
·
5 Posts
Thank you so much for your answer, indeed I did not catch it when reading the different threads.

So MHI2= a model of 718 from 2020 or later, I understand the 718 from 2019 is out of scope then...
If MY19 then the external module may be the solution...

I will add this condition in my search now :)
 

·
Registered
Joined
·
60 Posts
There are even some 2021 models still running on MHI2. I do not have a list for this 😉.
MJ2019 should still be high chance for MHI2.

MHI2 units started on Audi from 2015 on (TT) not sure when Porsche started to use them.

Other people here might have a better idea.

You could even take a M.I.B SD with you and check on GPS antenna during test drive 😉.

PCM4/4.1 work with M.I.B.
PCM5+ not.
 

·
Registered
2018 Cayman, Night Blue Metallic, PDK, Sport Chrono, Aluminum trim, Chalk/Black leather
Joined
·
8 Posts
Does installing this remove the Porsche and Cayman logo on startup?
 
221 - 240 of 261 Posts
Top