Porsche 718 Forum banner
321 - 340 of 366 Posts

·
Registered
Joined
·
3 Posts
Your unit is not patched:
View attachment 45175
You have to add patch files to your SD card. At least the one for yout units FW version.

View attachment 45176
I saw that scrolling through the log and it caught my eye for sure. I thought I downloaded the appropriate patch file from the MIB site but maybe not 🤔. Or maybe I put it in the wrong location on the SD card. Feeling foolish today 😂 thank you for looking over it! Definitely missing something somewhere. I have the latest patch from the source link downloaded on the card in the "patches" folder where it says "copy patches here". I must be overlooking something silly simple.

Yup, I see it now. I dind't properly unpack and copy the patches. I just copied the whole patch download. SMH. go ahead, slap me now!
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
Hi. I am looking to doing this to my 2017 718S to add Apple CarPlay. A couple of questions:

Q1. I have downloaded the latest MIB version, unpacked it onto a SD card and also added the patches. I was looking through the patch list and it does not list my software version. I wanted to check before I put the SD card into the unit and tried to run it as I don't think it will work. My software version is not in the patch list or on the MIB Tool v3.3.0 compatibility table. Will it work?

My software version is:

MHI2_US_POG11_K3300 0809

Q2. Assuming I can run the MIB …. The main reason I am doing this is to add Apple CarPlay …my car does not have navigation and I assume no GPS arial. I know one could be retrofitted, but as I have no interest in using the Porsche navigation I was going to leave as is. Do I get an an option to select desired added functionality e.g. add Apple CarPlay and NOT add navigation, or is everything added by default when MIB is run? I think it's the latter but wanted to check.


Many thanks for any feedback
 

·
Registered
Joined
·
28 Posts
I have some of the same questions as Hutch above.

I have a 2018 718 GTS with no nav, no carplay, no porsche connect (meaning I only have a glovebox USB). I only want (and will use) Android Auto (no need for nav, etc). From reading all of these threads (and others in other forums) It looks like MIB will work fine for me just by following the patching procedures in this thread, right? I don't have to do anything special to configure/tell MIB that I only have the glovebox USB, do I?

Also, I noticed that the github wiki now mentions that there is an automatic install for MIB (which is recommended). Is there any reason we shouldn't use the automatic install (not sure if anyone has tried it on a 718 yet).

Thanks all!!
 

·
Registered
Joined
·
110 Posts
@Racingtiger03
@hutch
@ajcarson11

As you all run MHI2_US_POG11 FW versions, best way for you is to update and patch your unit with the MHI2_US_POG11_K5186_1_MU1476_AIO FW.


Download: MIB Solution :: Login
Font Rectangle Number Art Circle



If you do not want to use Navigation, just do not use it ;)
But it also does not hurt to activate it even adding the GPS antenna is not too complicated.
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
@Racingtiger03
@hutch
@ajcarson11

As you all run MHI2_US_POG11 FW versions, best way for you is to update and patch your unit with the MHI2_US_POG11_K5186_1_MU1476_AIO FW.


Download: MIB Solution :: Login
View attachment 45228


If you do not want to use Navigation, just do not use it ;)
But it also does not hurt to activate it even adding the GPS antenna is not too complicated.
Many thanks for the response.

For my clarity, to patch my unit with the version you mention, using the latest MIB I have downloaded (version V3.4.1) and the automatic installation process will not work and I need the different file that you linked and I pasted below?

"MHI2 US POG11 K5186 1 MU1476 AI0 20220723"

Apologies for the newbie question … wanted to double check.

Totally get your point about the navigation!

Many thanks.
 

·
Registered
Joined
·
45 Posts
@Racingtiger03
@hutch
@ajcarson11

As you all run MHI2_US_POG11 FW versions, best way for you is to update and patch your unit with the MHI2_US_POG11_K5186_1_MU1476_AIO FW.


Download: MIB Solution :: Login
View attachment 45228


If you do not want to use Navigation, just do not use it ;)
But it also does not hurt to activate it even adding the GPS antenna is not too complicated.
Thanks - so the generic installer with the complete patches folder will still do the same thing on a 2018 718? Seems like it does a bunch of automatic activations that we would want :)

Looks like after reading all the docs that Bose is well understood and won't be hurt by this update.
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
The AIO is fully automated and gives you all what is possible won your PCM unit.
For GPS you might need to add a GPS antenna.
Thanks. Downloading this AIO as I type.

The installation instructions reinforce having the battery fully charged and attached to an external power supply / charger to avoid power lose during installation. I was wondering why not just turn on the car ignition on and have the car running. Any reason why this should not be done? Seems the easiest and best solution.

cheers.
 

·
Registered
Joined
·
45 Posts
The deed is done with the fully automated AIO. My build sheet and post update PCM screen is below, and now Nav is working and the Car page has the SC option available. Don't even need to purchase a GPS antenna. Bravo!

Only one concern, the icon I had on the lower left for Porsche Connect is no longer visible, and the Device Manager doesn't have a WiFi hotspot shown to activate for Precision Track. Do I need to change the config using GEM?

White Automotive design Steering part Car Vehicle



Font Screenshot Number Document Parallel
 

·
Registered
Joined
·
110 Posts
@hutch
VAG is always stating not to flash under engine power. Power fluctuations might get you bad blocks during writing.

@cbracerx
Nice! Cool that you have even GPS installed. Sometimes it seems to be connected to CarPlay already enabled from factory. I see Porsche connect in your list?! Strange to have that without navigation… you might have to activate it again. But the button still should show up. Did you have an active license?
WLAN is activated, just try to find it on your phone.
 

·
Registered
Joined
·
45 Posts
@cbracerx
Nice! Cool that you have even GPS installed. Sometimes it seems to be connected to CarPlay already enabled from factory. I see Porsche connect in your list?! Strange to have that without navigation… you might have to activate it again. But the button still should show up. Did you have an active license?
WLAN is activated, just try to find it on your phone.
[/QUOTE]

The WLAN is indeed showing - so that activation is working and no need for device manager I guess. I don't have an active Porsche Connect license, but before the update a disabled Connect icon was shown on the lower left. Since it didn't do anything perhaps having it hidden is for the best.

Despite plenty of references to the procedure to show the GEM - I am still unclear. Is this shown after pressing the Car and Media hard buttons together for 20 secs? Or the car and media soft buttons on the screen? I tried both without the GEM displaying. But user error here is certainly possible! :)
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
@hutch
VAG is always stating not to flash under engine power. Power fluctuations might get you bad blocks during writing.

@cbracerx
Nice! Cool that you have even GPS installed. Sometimes it seems to be connected to CarPlay already enabled from factory. I see Porsche connect in your list?! Strange to have that without navigation… you might have to activate it again. But the button still should show up. Did you have an active license?
WLAN is activated, just try to find it on your phone.
Ran the AIO update … few worrying times during the multiple reboots with a blank screen for prolonged periods, but it all worked! Now have Apple CarPlay plus the other goodies. Navigation was also added, but my car as I expected did not have the GPS antenna. Not sure I will retrofit as I didnt plan to use it in the base.

Thanks for all the feedback.
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
@cbracerx
Nice! Cool that you have even GPS installed. Sometimes it seems to be connected to CarPlay already enabled from factory. I see Porsche connect in your list?! Strange to have that without navigation… you might have to activate it again. But the button still should show up. Did you have an active license?
WLAN is activated, just try to find it on your phone.
The WLAN is indeed showing - so that activation is working and no need for device manager I guess. I don't have an active Porsche Connect license, but before the update a disabled Connect icon was shown on the lower left. Since it didn't do anything perhaps having it hidden is for the best.

Despite plenty of references to the procedure to show the GEM - I am still unclear. Is this shown after pressing the Car and Media hard buttons together for 20 secs? Or the car and media soft buttons on the screen? I tried both without the GEM displaying. But user error here is certainly possible! :)
[/QUOTE]
I just did the upgrade .. to get into the GEM I used the CAR & TUNER button together. I tried the screen soft buttons and these didn’t work, but the hard keys did. This may be the reason yours didn’t work as you said you were trying CAR and MEDIA.
@cbracerx
Nice! Cool that you have even GPS installed. Sometimes it seems to be connected to CarPlay already enabled from factory. I see Porsche connect in your list?! Strange to have that without navigation… you might have to activate it again. But the button still should show up. Did you have an active license?
WLAN is activated, just try to find it on your phone.
The WLAN is indeed showing - so that activation is working and no need for device manager I guess. I don't have an active Porsche Connect license, but before the update a disabled Connect icon was shown on the lower left. Since it didn't do anything perhaps having it hidden is for the best.

Despite plenty of references to the procedure to show the GEM - I am still unclear. Is this shown after pressing the Car and Media hard buttons together for 20 secs? Or the car and media soft buttons on the screen? I tried both without the GEM displaying. But user error here is certainly possible! :)
[/QUOTE]
I just did the upgrade .. to get into the GEM I used the CAR & TUNER button together. I tried the screen soft buttons and these didn’t work, but the hard keys did. This may be the reason yours didn’t work as you said you were trying CAR and MEDIA.
 

·
Registered
Joined
·
28 Posts
I'm not able to get the car to automatically initiate the install process -- I've tried 3 different SD cards now (all formatted to FAT32 using Windows, all containing only the files extracted from ...MU1476.7z. Any ideas on what else I can do? Do I need to seek out additional SD cards? I can confirm my version is MHI2_US_POG11_P4151 (which is compatible according to the wiki page).
 

·
Registered
2017 Boxster 718S
Joined
·
14 Posts
One "issue" I have now with AIO update is that the car clock seems to be be setting the time off the Navigation that has been added and as I don't have a GPS antenna installed (non-navigation car originally) it is defaulting to a different time zone (maybe a PCM/GPS default). If I correct the time, it resets within a minute.

I thought to solve this that maybe I could turn off the automatic time zone in the car settings menu… but it seems greyed out and defaulted to 'ON' . Not sure why it is greyed. (see picture below)

Plant Car Vehicle Automotive design Mode of transport


I was originally planning not to add the GPS antenna as I don't intend to use the Porsche navigation … but maybe I need to no … assuming this will fix it. I need the car clock to be correct!

Anyone know of any solutions?

Many thanks
 

·
Registered
2018 Cayman 2.0
Joined
·
392 Posts
With the early M.I.B. command line process, you had to toggle the NAV on, so I'm going to assume that you could toggle it off with that process. But I don't know if the early M.I.B. zip file is still available.

EDIT - Looks like the old M.I.B. files are still available. I think you want the one I highlighted below. This requires you to put the loaded SD card into SD1 (SD2 won't work), and then enter GEM by pressing and holding the CAR + TUNER buttons while the PCM is displaying the HOME screen. If the PCM switches to either the CAR or TUNER screens, go back to HOME and try again.

Once you get to the green menu, select M.I.B. (not production) and then read the menu choices carefully to find the Nav options. The Nav stuff is separate from CarPlay and AA in this package, so I think you should be able to disable Nav but leave CarPlay and AA active.
Rectangle Font Screenshot Parallel Software
 
321 - 340 of 366 Posts
Top