Porsche 718 Forum banner
181 - 200 of 261 Posts

·
Registered
Joined
·
657 Posts
Is the first step needed if the car has factory navigation?
If your PCM was set to have "Life Time Maps updates" then you should be able to proceed with just a map update. Extract the NAV DB onto a freshly formatted SD card (FAT32), insert that into SD1 on the PCM, and use the update process on the PCM to see if it recognizes the files and gives you the option to update.
 

·
Registered
Joined
·
19 Posts
If your PCM was set to have "Life Time Maps updates" then you should be able to proceed with just a map update. Extract the NAV DB onto a freshly formatted SD card (FAT32), insert that into SD1 on the PCM, and use the update process on the PCM to see if it recognizes the files and gives you the option to update.
Thank you.
 

·
Registered
Joined
·
657 Posts
No worries keep us posted! The system will begin the updates and give percentages until completion which takes about 30 minutes, so I recommend that you have the engine off but the battery connected to a maintainer.

Two routes to initiate upgrade:
1) Nav->Opt->Set Nav-> Update map.
2) Starting with the PCM buttons: Home, Car, Set (on screen), System, Software Update, Load Update
 

·
Registered
Joined
·
7 Posts
Just completed this install/update to have AA auto and button fix. This was intimidating, HUGE shout out to @Westcoaster helped me a TON during this process.

I'm curious as to why patching should not be done with engine running, which I did not do? I started to have a fear moment when the cluster was prompting low battery and radio off prompt, this was all in accessory mode (I don't have a battery maintainer), I thought I might have did something wrong.
 

·
Registered
Joined
·
25 Posts
I had a similar experience the first time I tried to upgrade the NAV DB on my car, it turned out to be bad connections between the microSD card and the adapter I was using, failure to load at different point each time. I used a different adapter and the load progress faster/smoother without error to completion.
I got the Nav Map Update to finally work. You were right Westcoaster, I got a full sized 64GB SD Card with exFAT format(had been using various micros in adaptors), freshly installed the maps to the new SD card & installed No Problems, took about 15 minutes.
Computer Gadget Font Vehicle Personal luxury car

Communication Device Font Mobile device Gadget Display device


Many thanks Team!
 

·
Registered
Joined
·
657 Posts
I got the Nav Map Update to finally work. You were right Westcoaster, I got a full sized 64GB SD Card with exFAT format(had been using various micros in adaptors), freshly installed the maps to the new SD card & installed No Problems, took about 15 minutes.
View attachment 42792
View attachment 42793

Many thanks Team!
That's great, thanks for the update and information on the 64GB card in exFAT working for this! (y)
 

·
Registered
Joined
·
7 Posts
Just want to triple check the process here.
Car ordered w/o NAV option, w/GPS antenna, w/Apple CarPlay. So I just want to enable NAV.

Format SDCard, extract MIB files to SDCard and patch for the correct version I have.
Insert the SD card into slot SD1 of unit.
Enter Engineering/Red Menu to start SW Update. Select UPDATE, select SD card, select "M.I.B. Launcher V1.0", START update.
Installtion of M.I.B. on PCM will start. The unit will restart three time until update process is finished.
GEM will be activated as part of the installation.
SVM error has to be cleared via M.I.B. function in GEM after installation
Enter GEM
Find the option to enable NAV on GEM and done?

Is that correct? Or do I need to even patch it? Can GEM be ran from the SDCard to just enable NAV?

Thanks for all the help, currently waiting on the car to be delivered so I trying to get as much info as possible ready.
 

·
Registered
Joined
·
657 Posts
@jamesrg did you read post#62 where the steps are shown on how to do this process? These need to be done before you can use the GEM, once it has been enabled you can follow the steps to enable NAV.

Since it is early and your car is not here you have time to get ready for this, happy to answer any questions.

BTW, I am Westcoast from over on Rennlist. ;)
 

·
Registered
Joined
·
7 Posts
@jamesrg did you read post#62 where the steps are shown on how to do this process? These need to be done before you can use the GEM, once it has been enabled you can follow the steps to enable NAV.

Since it is early and your car is not here you have time to get ready for this, happy to answer any questions.

BTW, I am Westcoast from over on Rennlist. ;)
I did see that post, and wanted to triple check my thinking, also read that read me file.

thanks for the quick reply.
Thought I recognized the name :), and maybe even planet 9 days as well, lol.

probably will just attempt this DIY and save me some monies and not possibly delay my order.
 

·
Registered
Joined
·
657 Posts
I did see that post, and wanted to triple check my thinking, also read that read me file.

thanks for the quick reply.
Thought I recognized the name :), and maybe even planet 9 days as well, lol.

probably will just attempt this DIY and save me some monies and not possibly delay my order.
Yes, Planet 9 as well, I got tired of K-Man's incessant babble about Tesla, and found Renlist to be more up to date with stuff.

Anyway, hardly any downside to the DIY approach, a little effort is all, with NAV one of the few things the DIY will not enable is the map shown in the 4.5" TFT independently of what is displayed on the PCM.
 

·
Registered
Joined
·
7 Posts
Yes, Planet 9 as well, I got tired of K-Man's incessant babble about Tesla, and found Renlist to be more up to date with stuff.

Anyway, hardly any downside to the DIY approach, a little effort is all, with NAV one of the few things the DIY will not enable is the map shown in the 4.5" TFT independently of what is displayed on the PCM.
Lol, yeah he was pretty bad at times at Tesla. I dropped off there when I sold my Boxster for a 991.2, now I am back with a MY23 Spyder hopefully this fall is the ETA.

I read that about the display and totally fine with that limitation. I work in IT, and this seems to be not that complicated. Basically loading a patch, reboot, enter into GEM and enable NAV. Almost like a firmware update.

thanks for all the assistance thus far!
 

·
Registered
Joined
·
7 Posts
Hi all,

I'm unable to flash the patched image (MHI2_ER_POG11_P5185_MU1475_PATCH) because it can't find any suitable image to flash.The issue seems to be that the offset differs hence different filename > no file found.

When checking my backup folder on the SDCARD I can see that the original file has this offset: 0x00ba0000-3405F400 but the patched image has 0x00ba0000-3005F400.

Is it safe to rename the file and flash anyways? I guess no...

Would appreciate any input :)

Thanks!

Edit:

Noticed that my backup image was 18.5MB instead of 16MB. On inspection with a hex-editor I can see that the extra 2.5MB is just padding (FFFFFFFF...). I think that I will try and do a new clean backup. To be continued...

Rectangle Font Material property Parallel Pattern
 

Attachments

·
Registered
Joined
·
657 Posts
Hi all,

I'm unable to flash the patched image (MHI2_ER_POG11_P5185_MU1475_PATCH) because it can't find any suitable image to flash.The issue seems to be that the offset differs hence different filename > no file found.

When checking my backup folder on the SDCARD I can see that the original file has this offset: 0x00ba0000-3405F400 but the patched image has 0x00ba0000-3005F400.

Is it safe to rename the file and flash anyways? I guess no...

Would appreciate any input :)

Thanks!
Interesting I got that same message on my first attempt, found that I didn't copy the complete patch folder into the Patch folder...

Also I went looking in the log for the offset information, does your backup have, in addition to the .ifs file and OFFSET file (.txt)?
 
181 - 200 of 261 Posts
Top